Bug sur la recherche

Messages de la modération et de l'administration et certains contenus autorisés (invitations à des rencontres IRL...)
Message
Auteur
defrance69

Bug sur la recherche

#1 Message par defrance69 » 18 déc. 2011, 11:36

et pas de chance cela tombe un dimanche...
Modifié en dernier par defrance69 le 25 févr. 2012, 12:25, modifié 2 fois.

defrance69

Re: Bug sur la recherche

#2 Message par defrance69 » 18 déc. 2011, 14:53

cela à l'air de remarcher

defrance69

Re: Bug sur la recherche

#3 Message par defrance69 » 18 déc. 2011, 14:57

Le forum est tombé après un banal vidage du cache de matin, après contact de jmp qui avait des activités familiales ce dimanche, j'ai récupéré des droits admins pour la journée histoire de faire les vérifications nécessaire du système.

Gei
~~+
~~+
Messages : 12617
Enregistré le : 09 nov. 2008, 09:22

Re: Bug sur la recherche

#4 Message par Gei » 18 déc. 2011, 15:00

Si JMP avait été en Chine pour une sombre histoire de virement bancaire, on aurait été bon pour passer Noël et le jour de l'an à la bougie ?

'Mot2Cambronne' alors ! :?

defrance69

Re: Bug sur la recherche

#5 Message par defrance69 » 18 déc. 2011, 15:01

Que je sache il y a aussi internet en chine...

Edit, le site est de nouveau actif mais on est encore en vrac : la fonction de recherche n'est plus active...

defrance69

Re: Bug sur la recherche

#6 Message par defrance69 » 18 déc. 2011, 15:16

en effectuant quelques tests, c'est l'indexation des mots que l'on a perdu
Il doit y avoir une manip à lancer pour la reconstituer mais j'ai un plantage sur la console d'admin sur la page de gestion de la recherche
je continu mes recherches

Avatar du membre
LCD 94 cm
+
+
Messages : 3492
Enregistré le : 12 nov. 2007, 14:50
Localisation : 東京

Re: Bug sur la recherche

#7 Message par LCD 94 cm » 18 déc. 2011, 18:03

defrance69 a écrit :Que je sache il y a aussi internet en chine...

Edit, le site est de nouveau actif mais on est encore en vrac : la fonction de recherche n'est plus active...
Internet est très filtré en Chine.
Image

defrance69

Bug sur la recherche

#8 Message par defrance69 » 18 déc. 2011, 18:06

Quand je vois le nombre de personne qui tente de s'inscrire a partir de chine?

Avatar du membre
LCD 94 cm
+
+
Messages : 3492
Enregistré le : 12 nov. 2007, 14:50
Localisation : 東京

Re: Bug sur la recherche

#9 Message par LCD 94 cm » 18 déc. 2011, 18:09

defrance69 a écrit :Quand je vois le nombre de personne qui tente de s'inscrire a partir de chine?
Ta phrase étant au singulier, la réponse est "1" de toute évidence :D
Image

defrance69

Re: Bug sur la recherche

#10 Message par defrance69 » 18 déc. 2011, 18:11

LCD 94 cm a écrit :
defrance69 a écrit :Quand je vois le nombre de personne qui tente de s'inscrire a partir de chine?
Ta phrase étant au singulier, la réponse est "1" de toute évidence :D
il y a effectivement un nombre que je regarde, mais il n'est pas forcément 1
sur la 50taine de demande d'ouverture de compte hebdo ce serai plutot 4-5 suivit par les russes...

12°5
+
+
Messages : 3185
Enregistré le : 01 mai 2011, 19:13

Re: Bug sur la recherche

#11 Message par 12°5 » 18 déc. 2011, 18:18

defrance69 a écrit :Le forum est tombé après un banal vidage du cache de matin, après contact de jmp qui avait des activités familiales ce dimanche, j'ai récupéré des droits admins pour la journée histoire de faire les vérifications nécessaire du système.
je croyais qu'il n'était plus admin :shock:

et slash (admin) était d'astreinte aujourd'hui....
in memoriam jeanguimauve (28 Déc 2007/06 nov 2011)

defrance69

Re: Bug sur la recherche

#12 Message par defrance69 » 18 déc. 2011, 18:23

12°5 a écrit :
defrance69 a écrit :Le forum est tombé après un banal vidage du cache de matin, après contact de jmp qui avait des activités familiales ce dimanche, j'ai récupéré des droits admins pour la journée histoire de faire les vérifications nécessaire du système.
je croyais qu'il n'était plus admin :shock:

et slash (admin) était d'astreinte aujourd'hui....
ce n'est pas un plantage du forum en tant que tel mais de la base d'indexation...
j'attend le retour de JMP pour revenir à nouveau un simple mortel...

12°5
+
+
Messages : 3185
Enregistré le : 01 mai 2011, 19:13

Re: Bug sur la recherche

#13 Message par 12°5 » 18 déc. 2011, 20:43

Pouretant tu sais qu'on ne doit pas déranger jmp un dimanche :evil:

viewtopic.php?f=2&t=32439
in memoriam jeanguimauve (28 Déc 2007/06 nov 2011)

defrance69

Re: Bug sur la recherche

#14 Message par defrance69 » 19 déc. 2011, 15:04

bon ben ma réparation de fortune n'aura duré que 24h
on s'y remet à 16h

Avatar du membre
Gustave de Nancy
~~+
~~+
Messages : 7294
Enregistré le : 28 oct. 2011, 14:24

Re: Bug sur la recherche

#15 Message par Gustave de Nancy » 04 janv. 2012, 17:52

Bon ça donne quoi parce que la base est pétée pour tout l'historique avant le 27 décembre la.
Image

Avatar du membre
neron
~~+
~~+
Messages : 12604
Enregistré le : 21 déc. 2005, 19:21
Localisation : Haut de Seine

Re: Bug sur la recherche

#16 Message par neron » 04 janv. 2012, 23:19

Y-a comme un lapin .

Par exemple je ne trouve pas les amis qui m'ont cités depuis le 29 décembre par exemple là viewtopic.php?f=4&t=77444&p=1429599&hil ... l#p1429599 ou là viewtopic.php?f=116&t=77416&p=1428511&h ... b#p1428511

Si ça peut aider , c'était pour faire avancer le chimiliblic

Sincèrement, merci encore pour toute cette année de dévouement derrière les manettes et meilleurs
vœux de santé , de bonheur et de prospérité voir encore plus à ceux qui font marcher ce truc :)

Avatar du membre
krachboom
~~+
~~+
Messages : 5589
Enregistré le : 18 sept. 2008, 10:22

Re: Bug sur la recherche

#17 Message par krachboom » 26 janv. 2012, 17:43

Bonjour, j'aimerai bien savoir si on peut espérer avoir un jour une vraie fonction "recherche" sur ce forum :cry:

j'utilise pas mal de forum qui sont phpBB et qui n'ont pas ce type de pb (surtout quand on fait de la recherche que sur le titre des sujets)

Avatar du membre
Gustave de Nancy
~~+
~~+
Messages : 7294
Enregistré le : 28 oct. 2011, 14:24

Re: Bug sur la recherche

#18 Message par Gustave de Nancy » 30 janv. 2012, 16:27

Up.

C'est quand même inquiétant que vous n'ayez pas accès à ce qu'il faut dans l'administration pour corriger ce problème.
Image

defrance69

Re: Bug sur la recherche

#19 Message par defrance69 » 22 févr. 2012, 23:37

Bonjour à tous
après quelques recherches, la fonction de recherche semble de nouveau fonctionner
le problème semble provenir du tsearch_builtin

Avatar du membre
Ahsoka Tano
-++
-++
Messages : 4940
Enregistré le : 17 déc. 2011, 01:01

Re: Bug sur la recherche

#20 Message par Ahsoka Tano » 22 févr. 2012, 23:47

defrance69 a écrit :Bonjour à tous
après quelques recherches, la fonction de recherche semble de nouveau fonctionner
le problème semble provenir du tsearch_builtin
J'ai surtout l'impression que la fonction recherche rame grave de chez grave...
Nabu a écrit :Le véritable danger pour la République Française et pour la démocratie, ce n'est pas le FN, mais des gens comme Mélenchon!
FoX a écrit :Pour le plus "discuté" d'entre eux, à savoir le FN : ce parti n'est PAS un parti d'extrême droite, à proprement parler.

defrance69

Re: Bug sur la recherche

#21 Message par defrance69 » 22 févr. 2012, 23:50

Ahsoka Tano a écrit :
defrance69 a écrit :Bonjour à tous
après quelques recherches, la fonction de recherche semble de nouveau fonctionner
le problème semble provenir du tsearch_builtin
J'ai surtout l'impression que la fonction recherche rame grave de chez grave...
l'indexation doit se reconstruire posgress-ivement faut croire...

Avatar du membre
Ahsoka Tano
-++
-++
Messages : 4940
Enregistré le : 17 déc. 2011, 01:01

Re: Bug sur la recherche

#22 Message par Ahsoka Tano » 22 févr. 2012, 23:53

defrance69 a écrit :
Ahsoka Tano a écrit :
defrance69 a écrit :Bonjour à tous
après quelques recherches, la fonction de recherche semble de nouveau fonctionner
le problème semble provenir du tsearch_builtin
J'ai surtout l'impression que la fonction recherche rame grave de chez grave...
l'indexation doit se reconstruire posgress-ivement faut croire...
Faut voir, il y avait déjà ce problème avant que tu ne casses la recherche... si c'est du cache postgres, ça continuera à ramer.
Nabu a écrit :Le véritable danger pour la République Française et pour la démocratie, ce n'est pas le FN, mais des gens comme Mélenchon!
FoX a écrit :Pour le plus "discuté" d'entre eux, à savoir le FN : ce parti n'est PAS un parti d'extrême droite, à proprement parler.

defrance69

Re: Bug sur la recherche

#23 Message par defrance69 » 22 févr. 2012, 23:56

Ahsoka Tano a écrit :
defrance69 a écrit :
Ahsoka Tano a écrit :
defrance69 a écrit :Bonjour à tous
après quelques recherches, la fonction de recherche semble de nouveau fonctionner
le problème semble provenir du tsearch_builtin
J'ai surtout l'impression que la fonction recherche rame grave de chez grave...
l'indexation doit se reconstruire posgress-ivement faut croire...
Faut voir, il y avait déjà ce problème avant que tu ne casses la recherche... si c'est du cache postgres, ça continuera à ramer.
Où as-tu vu que j'ai cassé la recherche?

Avatar du membre
Ahsoka Tano
-++
-++
Messages : 4940
Enregistré le : 17 déc. 2011, 01:01

Re: Bug sur la recherche

#24 Message par Ahsoka Tano » 23 févr. 2012, 00:10

defrance69 a écrit :Où as-tu vu que j'ai cassé la recherche?
Ben elle marchait, puis elle a cessé de fonctionner. Or tu es le seul à intervenir sur la serveur.
Mais les erreurs ça arrive, c'est quand on les dénie que c'est triste.
Nabu a écrit :Le véritable danger pour la République Française et pour la démocratie, ce n'est pas le FN, mais des gens comme Mélenchon!
FoX a écrit :Pour le plus "discuté" d'entre eux, à savoir le FN : ce parti n'est PAS un parti d'extrême droite, à proprement parler.

defrance69

Re: Bug sur la recherche

#25 Message par defrance69 » 23 févr. 2012, 00:15

defrance69 a écrit :Le forum est tombé après un banal vidage du cache de matin, après contact de jmp qui avait des activités familiales ce dimanche, j'ai récupéré des droits admins pour la journée histoire de faire les vérifications nécessaire du système.
j'aime bien me citer, effectivement la fonction de recherche est tombé en rade suite à une intervention de maintenance de ma part, intervention que j'avais réaliser de nombreuses fois auparavant sans le moindre problème, donc si tu penses que c'est ma faute c'est ton droit, je laisse l'interprétation à d'autres...
mais faut pas d'un coté gueuler que l'on ne fout rien et de l'autre gueuler quand on fait quelquechose...

Avatar du membre
Ahsoka Tano
-++
-++
Messages : 4940
Enregistré le : 17 déc. 2011, 01:01

Re: Bug sur la recherche

#26 Message par Ahsoka Tano » 23 févr. 2012, 00:17

defrance69 a écrit :
defrance69 a écrit :Le forum est tombé après un banal vidage du cache de matin, après contact de jmp qui avait des activités familiales ce dimanche, j'ai récupéré des droits admins pour la journée histoire de faire les vérifications nécessaire du système.
j'aime bien me citer, effectivement la fonction de recherche est tombé en rade suite à une intervention de maintenance de ma part, intervention que j'avais réaliser de nombreuses fois auparavant sans le moindre problème, donc si tu penses que c'est ma faute c'est ton droit, je laisse l'interprétation à d'autres...
C'est la vie, avec l'habitude tu as pu te la jouer facile et du coup tu as raté un truc. Ce n'est pas grave en soi mais le déni n'est pas une réponse adaptée. Rater un truc que l'on a l'habitude de réussir c'est que l'on est pas concentré, la machine ne fait que ce que tu lui dis de faire...
Nabu a écrit :Le véritable danger pour la République Française et pour la démocratie, ce n'est pas le FN, mais des gens comme Mélenchon!
FoX a écrit :Pour le plus "discuté" d'entre eux, à savoir le FN : ce parti n'est PAS un parti d'extrême droite, à proprement parler.

defrance69

Re: Bug sur la recherche

#27 Message par defrance69 » 23 févr. 2012, 00:20

j'attend donc avec impatience tes explications sur le plantage lié au vidage du cache de phpbb
je t'aide c'est lié au tsearch_builtin

Avatar du membre
Ahsoka Tano
-++
-++
Messages : 4940
Enregistré le : 17 déc. 2011, 01:01

Re: Bug sur la recherche

#28 Message par Ahsoka Tano » 23 févr. 2012, 00:44

defrance69 a écrit :j'attend donc avec impatience tes explications sur le plantage lié au vidage du cache de phpbb
je t'aide c'est lié au tsearch_builtin
La résolution apparente du problème n'empêche pas qu'il y ait eu problème. Si tu as trouvé une solution c'est tant mieux, mais il faudrait que tu relâches la pression, tu n'es pas invulnérable picétou.
Nabu a écrit :Le véritable danger pour la République Française et pour la démocratie, ce n'est pas le FN, mais des gens comme Mélenchon!
FoX a écrit :Pour le plus "discuté" d'entre eux, à savoir le FN : ce parti n'est PAS un parti d'extrême droite, à proprement parler.

defrance69

Re: Bug sur la recherche

#29 Message par defrance69 » 23 févr. 2012, 00:45

en attendant j'ai l'impression que j'ai réglé un truc mais qu'il reste un pb

Avatar du membre
Ahsoka Tano
-++
-++
Messages : 4940
Enregistré le : 17 déc. 2011, 01:01

Re: Bug sur la recherche

#30 Message par Ahsoka Tano » 23 févr. 2012, 00:47

defrance69 a écrit :en attendant j'ai l'impression que j'ai réglé un truc mais qu'il reste un pb
Nous sommes d'accord. A priori on en revient à la situation d'avant, les recherches fonctionnent mais mettent un temps fou à se faire.
Nabu a écrit :Le véritable danger pour la République Française et pour la démocratie, ce n'est pas le FN, mais des gens comme Mélenchon!
FoX a écrit :Pour le plus "discuté" d'entre eux, à savoir le FN : ce parti n'est PAS un parti d'extrême droite, à proprement parler.

defrance69

Re: Bug sur la recherche

#31 Message par defrance69 » 23 févr. 2012, 00:57

Ahsoka Tano a écrit :
defrance69 a écrit :en attendant j'ai l'impression que j'ai réglé un truc mais qu'il reste un pb
Nous sommes d'accord. A priori on en revient à la situation d'avant, les recherches fonctionnent mais mettent un temps fou à se faire.
non elles vont plus loin que décembre 2011...
le problème semble venir de la version 9 de postgres et de l'activation du tsearch_builtin dans le fulltext_postgres
le genre de truc qu'il ne faut pas s'amuser à toucher à 1h du mat donc on verra cela ce week-end

Avatar du membre
slash33
~~+
~~+
Messages : 47081
Enregistré le : 21 mai 2005, 12:37

Re: Bug sur la recherche

#32 Message par slash33 » 23 févr. 2012, 08:00

Heu... bon on va faire simple:
- qu'est-ce qui a été corrigé et à quel niveau,
- quelle est la pérénité de la solution,
- quels sont les problèmes restants/induits

:?:

J'ai toujours un index qui ne présente rien d'antérieur à janvier 2012 perso.

Avatar du membre
slash33
~~+
~~+
Messages : 47081
Enregistré le : 21 mai 2005, 12:37

Re: Bug sur la recherche

#33 Message par slash33 » 23 févr. 2012, 08:03

Est-ce que tu as reconstruit l'index Postgré après ta modif? C'est dans l'onglet maintenance de la console d'administration.

defrance69

Re: Bug sur la recherche

#34 Message par defrance69 » 23 févr. 2012, 08:21

slash33 a écrit :Est-ce que tu as reconstruit l'index Postgré après ta modif? C'est dans l'onglet maintenance de la console d'administration.
en fait je ne pense pas que ce soit nécessaire puisque l'index était déjà existant, je le relance au cas où

defrance69

Re: Bug sur la recherche

#35 Message par defrance69 » 23 févr. 2012, 08:21

slash33 a écrit :Est-ce que tu as reconstruit l'index Postgré après ta modif? C'est dans l'onglet maintenance de la console d'administration.
en fait je ne pense pas que ce soit nécessaire puisque l'index était déjà existant, je le relance au cas où

defrance69

Re: Bug sur la recherche

#36 Message par defrance69 » 23 févr. 2012, 08:29

la modif est dans le code du fulltext_postgres.php, le basculement à la V9 n'a pas l'air d'être correctement implémenté (j'ai retrouvé des commentaires sur le site de phpbb sur le sujet)

coté recherche, je vais plus loin que décembre 2011 sur certains mots, donc la recherche fonctionne de nouveau correctement, seul soucis sa vitesse qui me fait penser qu'il y a une optimisation à faire quelque part encore...

l'index étant déjà existant je ne pense pas que ce soit nécessaire de le reconstruire mais j'ai relancé le traitement on verra bien...

Avatar du membre
slash33
~~+
~~+
Messages : 47081
Enregistré le : 21 mai 2005, 12:37

Re: Bug sur la recherche

#37 Message par slash33 » 23 févr. 2012, 18:01

Perso j'ai essayé une recherche globale sur le mot clé "mouillard": le serveur n'a jamais répondu. :roll:

Avatar du membre
Ahsoka Tano
-++
-++
Messages : 4940
Enregistré le : 17 déc. 2011, 01:01

Re: Bug sur la recherche

#38 Message par Ahsoka Tano » 23 févr. 2012, 18:04

slash33 a écrit :Perso j'ai essayé une recherche globale sur le mot clé "mouillard": le serveur n'a jamais répondu. :roll:
Pareil sur plusieurs recherches, on en revient au bug précédant le problème des posts d'avant 2012 qui n'apparaissent pas.
Nabu a écrit :Le véritable danger pour la République Française et pour la démocratie, ce n'est pas le FN, mais des gens comme Mélenchon!
FoX a écrit :Pour le plus "discuté" d'entre eux, à savoir le FN : ce parti n'est PAS un parti d'extrême droite, à proprement parler.

defrance69

Re: Bug sur la recherche

#39 Message par defrance69 » 23 févr. 2012, 19:53

slash33 a écrit :Perso j'ai essayé une recherche globale sur le mot clé "mouillard": le serveur n'a jamais répondu. :roll:
J'ai eu de la chance, il m'a répondu :mrgreen: avec des refs de message datant de janvier 2011
par contre j'attend toujours pour foreclosuregate... et il m'a répondu 209 messages dont un datant de 2010 viewtopic.php?f=122&t=32785&p=1149879&h ... e#p1149879
pour friggit c'est plus rapide

Avatar du membre
Ahsoka Tano
-++
-++
Messages : 4940
Enregistré le : 17 déc. 2011, 01:01

Re: Bug sur la recherche

#40 Message par Ahsoka Tano » 23 févr. 2012, 21:21

alain2908 a écrit :
Ahsoka Tano a écrit :
defrance69 a écrit :
defrance69 a écrit :Le forum est tombé après un banal vidage du cache de matin, après contact de jmp qui avait des activités familiales ce dimanche, j'ai récupéré des droits admins pour la journée histoire de faire les vérifications nécessaire du système.
j'aime bien me citer, effectivement la fonction de recherche est tombé en rade suite à une intervention de maintenance de ma part, intervention que j'avais réaliser de nombreuses fois auparavant sans le moindre problème, donc si tu penses que c'est ma faute c'est ton droit, je laisse l'interprétation à d'autres...
C'est la vie, avec l'habitude tu as pu te la jouer facile et du coup tu as raté un truc. Ce n'est pas grave en soi mais le déni n'est pas une réponse adaptée. Rater un truc que l'on a l'habitude de réussir c'est que l'on est pas concentré, la machine ne fait que ce que tu lui dis de faire...
y a qu'un informaticien pour penser ca.
plus personne ne controle le moindre programme sophistiqué de nos jours
phpbb un logiciel sophistiqué... franchement alain, LOL.
Nabu a écrit :Le véritable danger pour la République Française et pour la démocratie, ce n'est pas le FN, mais des gens comme Mélenchon!
FoX a écrit :Pour le plus "discuté" d'entre eux, à savoir le FN : ce parti n'est PAS un parti d'extrême droite, à proprement parler.

defrance69

Re: Bug sur la recherche

#41 Message par defrance69 » 23 févr. 2012, 21:39

Ahsoka Tano a écrit : phpbb un logiciel sophistiqué... franchement alain, LOL.
puisque c'est si simple, tu as des infos à me donner sur tsearch_builtin ?
j'ai un truc qui plante là t'as un avis éclairé à me donner?

Code : Tout sélectionner

if ($pgsql_version[0] > 8 || ($pgsql_version[0] == 8 && $pgsql_version[1] >= 3)
j'ai aussi remplacé ca

Code : Tout sélectionner

$tmp_sql_match[] = "to_tsvector ('" . $db->sql_escape($config['fulltext_postgres_ts_name']) . "', " . $sql_match_column . ") @@ to_tsquery ('" . $db->sql_escape($config['fulltext_postgres_ts_name']) . "', '" . $db->sql_escape($this->tsearch_query) . "')";
par ca

Code : Tout sélectionner

$tmp_sql_match[] = "to_tsvector ('" . $db->sql_escape($config['fulltext_postgres_ts_name']) . "'::regname, " . $sql_match_column . ") @@ to_tsquery ('" . $db->sql_escape($config['fulltext_postgres_ts_name']) . "'::regname, '" . $db->sql_escape($this->tsearch_query) . "')";
tu en penses quoi...

defrance69

Re: Bug sur la recherche

#42 Message par defrance69 » 23 févr. 2012, 22:04

bon je t'aide un peu
là : if ($pgsql_version[0] > 8 || ($pgsql_version[0] == 8 && $pgsql_version[1] >= 3)
il manquait juste une parenthèse à la fin ... fallait juste savoir lire et compter jusqu'à ... 2

Avatar du membre
Ahsoka Tano
-++
-++
Messages : 4940
Enregistré le : 17 déc. 2011, 01:01

Re: Bug sur la recherche

#43 Message par Ahsoka Tano » 23 févr. 2012, 22:06

Image
Duff, si tu as du mal avec les clauses "et" et "ou" en php, remets toi au vba.

Mais comme tu le demandes gentiment, je vais t'éclairer.

Là on teste la version de postgres en liant 2 clauses, on décompose de la façon suivante :

Note pour alain, la version d'un logiciel s'exprime par exemple en 8.3 ce que l'on décompose en un tableau dont le premier élément sera la version majeure (ici : 8) et le second élément le numéro dit mineur (ici : 3)
Le premier élément du tableau étant indexé 0, genre $pgsql_version[0] et le second élement est indexé ... 1 ... genre $pgsql_version[1].

Donc

Code : Tout sélectionner

if ($pgsql_version[0] > 8 
Si la version majeure est strictement supérieure à 8, pour postgres ça veut dire que toutes les versions 9.* sont compatibles ça signifie ou (à comprendre dans le sens première clause ou seconde clause, le fait qu'une des deux soit ok permet de rendre l'ensemble vrai)

Code : Tout sélectionner

 ($pgsql_version[0] == 8 && $pgsql_version[1] >= 3)
version majeure égale à 8 (donc 8.x) ET version mineure supérieure ou égale à 3, donc toutes les versions à partir de la 8.3 sont ok.

En résumé, ça signifie version 8.3 ou supérieure (les versions 9 le sont trivialement).

Trop dur ton quizz duff. Image
j'ai aussi remplacé ca

Code : Tout sélectionner

$tmp_sql_match[] = "to_tsvector ('" . $db->sql_escape($config['fulltext_postgres_ts_name']) . "', " . $sql_match_column . ") @@ to_tsquery ('" . $db->sql_escape($config['fulltext_postgres_ts_name']) . "', '" . $db->sql_escape($this->tsearch_query) . "')";
par ca

Code : Tout sélectionner

$tmp_sql_match[] = "to_tsvector ('" . $db->sql_escape($config['fulltext_postgres_ts_name']) . "'::regname, " . $sql_match_column . ") @@ to_tsquery ('" . $db->sql_escape($config['fulltext_postgres_ts_name']) . "'::regname, '" . $db->sql_escape($this->tsearch_query) . "')";
tu en penses quoi...
Tu as juste ajouté les "::regname", c'est un bricolage sur postgres, je connais plutôt mysql mais ça ressemble à un forçage de type ou d'index ?
Si tu as un pointeur sur la magie de regname (google est avare en pointeurs sur le sujet) je peux te donner un avis plus précis.
Nabu a écrit :Le véritable danger pour la République Française et pour la démocratie, ce n'est pas le FN, mais des gens comme Mélenchon!
FoX a écrit :Pour le plus "discuté" d'entre eux, à savoir le FN : ce parti n'est PAS un parti d'extrême droite, à proprement parler.

Avatar du membre
Ahsoka Tano
-++
-++
Messages : 4940
Enregistré le : 17 déc. 2011, 01:01

Re: Bug sur la recherche

#44 Message par Ahsoka Tano » 23 févr. 2012, 22:07

defrance69 a écrit :bon je t'aide un peu
là : if ($pgsql_version[0] > 8 || ($pgsql_version[0] == 8 && $pgsql_version[1] >= 3)
il manquait juste une parenthèse à la fin ... fallait juste savoir lire et compter jusqu'à ... 2
C'est la précédence des opérateurs et le parenthésage, si c'était ça ton piège tu aurais pu t'abstenir, tu es en train de passer pour un benet, avec n'importe quel bon éditeur tu évites ce genre de faute de syntaxe.
Nabu a écrit :Le véritable danger pour la République Française et pour la démocratie, ce n'est pas le FN, mais des gens comme Mélenchon!
FoX a écrit :Pour le plus "discuté" d'entre eux, à savoir le FN : ce parti n'est PAS un parti d'extrême droite, à proprement parler.

defrance69

Re: Bug sur la recherche

#45 Message par defrance69 » 23 févr. 2012, 22:18

ben ouai mais t'es mollement tombé dedans, tu petes ta science et t'en oublie les bases...

Avatar du membre
Jeffrey
Modérateur
Modérateur
Messages : 11790
Enregistré le : 12 févr. 2012, 19:59

Re: Bug sur la recherche

#46 Message par Jeffrey » 23 févr. 2012, 22:23

j'ai posté sur la file du simulateur , mais mon message n'apparait pas, la file dit que le dernier message est du 11 février, c'est aussi un bug?
Quis custodiet ipsos custodes?

defrance69

Re: Bug sur la recherche

#47 Message par defrance69 » 23 févr. 2012, 22:26

Jeffrey a écrit :j'ai posté sur la file du simulateur , mais mon message n'apparait pas, la file dit que le dernier message est du 11 février, c'est aussi un bug?
ton message doit être en approbation

Avatar du membre
Ahsoka Tano
-++
-++
Messages : 4940
Enregistré le : 17 déc. 2011, 01:01

Re: Bug sur la recherche

#48 Message par Ahsoka Tano » 23 févr. 2012, 22:30

defrance69 a écrit :ben ouai mais t'es mollement tombé dedans, tu petes ta science et t'en oublie les bases...
N'empèche que c'est pas glorieux, à ta place je m'en serais dispensé.

Plus généralement, as-tu vérifié que dans la base les index sont bien créés dans les deux tables utiles à la recherche ?

Si la page est à jour, tu dois avoir ceci :
http://wiki.phpbb.com/Table.phpbb_search_wordlist
http://wiki.phpbb.com/Table.phpbb_search_wordmatch

Intuitivement, je dirais que la recherche fait un tablescan, donc il doit manquer un index, ceci étant corrélé par le fait qu'une recherche d'un mot fréquent termine vite (aidé par la limite à 500 résultats) alors qu'un mot plus compliqué ne répond pas, signe qu'on scanne toute la table (et on finit par exploser la mémoire ou le temps de run d'un script).
Nabu a écrit :Le véritable danger pour la République Française et pour la démocratie, ce n'est pas le FN, mais des gens comme Mélenchon!
FoX a écrit :Pour le plus "discuté" d'entre eux, à savoir le FN : ce parti n'est PAS un parti d'extrême droite, à proprement parler.

defrance69

Re: Bug sur la recherche

#49 Message par defrance69 » 23 févr. 2012, 22:32

avec les fonctions fulltext tu ne passes pas par les tables d'index, c'est uniquement avec les recherches natives...

Avatar du membre
Ahsoka Tano
-++
-++
Messages : 4940
Enregistré le : 17 déc. 2011, 01:01

Re: Bug sur la recherche

#50 Message par Ahsoka Tano » 23 févr. 2012, 22:34

defrance69 a écrit :avec les fonctions fulltext tu ne passes pas par les tables d'index, c'est uniquement avec les recherches natives...
Dans ce cas les concepteurs de phpbb ont créé des index sur les tables juste pour ralentir phpbb ? Image
Nabu a écrit :Le véritable danger pour la République Française et pour la démocratie, ce n'est pas le FN, mais des gens comme Mélenchon!
FoX a écrit :Pour le plus "discuté" d'entre eux, à savoir le FN : ce parti n'est PAS un parti d'extrême droite, à proprement parler.